Cisco UCS Platform Emulator – ‘Slot ID Must Be A Range In The Format [a-b]’

This is another quick blog post to help anyone using the Cisco UCS Platform Emulator and is configuring a chassis or blade and runs into the error message ‘slot ID must be a range in the format [a-b]’

UCS Error01The [a-b] is misleading, however you do need to enter details in a specific format for it to be accepted by the Cisco UCS Platform Emulator.

The easiest way to do this is to jump onto Cisco UCS Manager and expand the component you are trying to add and check the properties of the item.

In the above case, I’m trying to add fans to a 5108 Chassis. So I have drilled down to the component and checked the format of the ID and Tray.

UCS Error02The format to enter the fans in is 1-1 or if you want to populate all 8 at once enter 1-8.

UCS Error03To give another example, I want to configure a Cisco UCS B200 M4 Blade and want to add in Intel(R) Xeon(R) E5-2650 v3 2.30 GHz 105W 10C/25MB Cache/DDR4 2133MHz.  The format for this is 1-2 which represents the CPU slots.UCS Error04

Cisco UCS Platform Emulator – Unable to Launch UCS Manager

This is a quick blog post to help anyone who is setting up and configuring Cisco UCS Platform Emulator for the first time and is staring blankly at a screen wondering why they have no ability to launch UCS Manager.

Problem Statement

Connecting to the VIP Address of the Cisco UCS Platform Emulator, you are unable to launch UCS Manager.

Cisco UCS 01

Solution

Cisco UCS Platform Emulator works under the premise of secure and un-secure context and therefore is blocked by FireFox.

Select the ‘shield icon’ in FireFox

Cisco UCS 02

 

Click Options

Cisco UCS 03

Select ‘Disable Protection Now’

Cisco UCS 04

 

Refresh and you can now Launch Cisco UCS Manager

Cisco UCS 05

vSphere 5.1 – Unable To Deploy VM From Template

Problem Statement

After upgrading to vSphere 5.1 you experience the following error ‘the public key in specification does not match the vCenter public key.  You have to reenter the password in order to proceed’ when trying to deploy new virtual machines from templates.

Error

Issue

The administrators password used to create the virtual machine was encrypted using a different Certificate Authority to the one installed on vCenter.  This means that the password is no longer trusted.

Resolution

In vCenter go to Home > Customization Specification Manager

Customization Specification 01

Edit Specification > 5 Administrator Password > Re Enter Credentials > Save

Customization Specification 02

If your Customization Specification is domain joined you will need to enter your credentials again under 9 Workgroup or Domain

Customization Specification 03

You will now be able to deploy your VM from the template in question.

Upgrade To vCenter 5.1: Unable To Authenticate Directly To ESXi Host Using Active Directory

Problem Statement

After upgrading to vCenter 5.1 and ESXi 5.1 U1, Active Directory authentication to an ESXi Host no longer works.  Using the vSphere Client error message ‘cannot complete login due to incorrect user name or password’ is received.

Authenticate 01

Quick Checks

1. Single Sign On checked, LDAP Active Directory authentication source working for vCenter and another ESXi Host.

2. Permissions checked, ‘Administrators’ Active Directory Security Group applied to vCenter and permissions propagated to child objects.

3. Authentication Services Services, Active Directory being used and Computer Object is valid.

Troubleshooting Steps

I tried to remove the host from Active Directory and re-authenticate.  Hosts and Clusters > Host > Settings > Manage > Authentication Services

Authenticate 02

An error message appeared stating that ‘the user or group named VMFOCUS\domain^admins does not exist’.

Authenticate 03

The Permissions tab on the affected ESXi Host didn’t show a VMFOCUS\domain^admins group

Authenticate 04

I added the VMFOCUS\Domain Admins group to the top level and inherited permissions.  Another quick try and I wasn’t able to login to the ESXi Host using the vSphere Client.

This time the Leave Domain setting worked.  Plus I also deleted the Computer Object for my ESXi Host from Active Directory.

Next, I rejoined the Domain and tried to login  directly to the ESXi Host directly using Active Directory credentials, which again failed.

Resolution

I added the Domain Admins group directly to the ESXi Host

Authenticate 05

When using the vSphere Client I deselected ‘Use Windows session credentials’ and manually entered Administrator and was able to login successfully!

Authenticate 06

Simple when you know what is causing the issue.

HP iLO2: Firmware Upgrade Via Webpage Failed

Trying to firmware upgrade HP iLO2 from version 2.07 or 1.81 to 2.22 results in the error message ‘firmware upgrade via webpage failed’  Using a .bin file via a Windows Server.

HPiLO01

Troubleshooting Steps

  • Enabled compatibility mode in IE9, this resulted in Firmware loading to 99% and then timing out
  • Enabled compatibility mode in IE10, again this resulted in Firmware loading to 99% and then timing out
  • Tried using Google Chrome, again this resulted in Firmware loading to 99% and then timing out

Resolution

It seems strange but the firmware upgrade will work using Mozilla Firefox.  Using this browser results in success, I’m now on iLO2 firmware 2.22.

HPiLO02